Donncha, thanks for your patience with me so far. I’m trying to find a list of system requirements for using 3.0 in a multiuser version, but so far it’s eluding me. For example, do I need a dedicated ip address, a dedicated server, etc. Admin on 3.0 is so easy, I want to move all my clients to a 3.0 install with BuddyPress and a forum for support — I’ll have to use your plugin because of course they’ll want to map their domain to their site and it needs to appear seamless to the outside world…