I’d think you’d need to work on moving them over to php 5 and apache 2.2 or at least look at mod_security etc as they really are legacy! http://php.net/ChangeLog-4.php (at least 2.0 apache is still active).