Do you have the exact error message? I presume it was something about mod_rewrite or one of the other Apache modules. That’s an issue for your server administrators as the module dependencies haven’t changed in years.

Perhaps they changed something around the same time you upgraded the plugin?