@Thom,

My guess is that the TinyMCE Advanced plugin uses WP_PLUGIN_URL and that is not pointing to the same domain as you have in the address bar of your browser when creating/editing a post. You’ll then get a cross-domain JavaScript error which is probably why that plugin does not work when the domain mapping plugin is also installed.

@Donncha,

Have you seen behaviour like this before? Should WP_PLUGIN_URL get updated to reflect the mapped domain?