Vikram – you’re using 2.8.4a, sorry for the confusion. The “You are using a development version” message should disappear next time your site checks the version number today.
Unfortunately the footer will say 2.8.4 on the right but that’s incorrect. The version number on the left is correct.