Ah, that can’t be fixed unfortunately. MU whitelists the options it’ll accept. WP 2.8 does too, but has a compatibility mode for legacy plugins.

Unfortunately it’s a huge security hole for MU sites because any admin can change any blog option and potentially execute PHP code.