Donncha,

I am getting that same error:

Warning: Invalid argument supplied for foreach() in /home/.toshibba/craigintwincities/historyhype.com/wp-content/plugins/blog-voyeur/voyeur.php on line 89

WordPress has not found/acknowledge the 0.2 upgrade to your plugin that fixes that. Since I prefer to update all my blog plugins using an automatic updater plugin, please do make sure this upgrade that corrects this problem gets taken care of soon, will you?

I appreciate it. Thanks!