Jim,
If you genuinely know of 6 WordPress 2.5.1 exploits, I encourage you to contact me as I will appropriately update WP Security Scan.