What exact version of PHP, Apache, MySQL are you running?