Waldy – you should upgrade. There aren’t that many changed files but there are security holes in WordPress itself. That’s why you should upgrade to 1.2.5a, not just wpmu-functions.php