Odd that you’d have issues with Wp-cache. I’ve been using it on my servers for quite some time and they all run php5 …

Michele