I was testing 2.5 for a while so it probably is a 2.5 issue. Very useful plugin too!