Apparently Fedora 15 has moved to Gnome 3, which is very restrictive and immature, so it suffers from a similar problem. Haven’t actually run it yet though.