Categories
Hardware

Yes, finally fixed the SSD freezing my computer!

TL;DR If your computer is freezing after installing an SSD change from AHCI to IDE mode in the BIOS.

Argh! This has been driving me slightly mad for a while. I bought a Samsung 840 SSD a few weeks ago to make things a bit faster. It does too, mostly to the boot up (which I rarely do, this machine is on 24×7) but it feels smoother in day to day tasks too.

SSD

I keep the Lightroom catalogue on the SSD, Windows 7 is on there too but most apps, all games and all photos are on other drives.

It worked fine for a while but then it started freezing and stuttering without warning. It was usually when I had a few dozen Chrome tabs open, Firefox running, Skype, xchat, and various services going. The mouse cursor would disappear and the keyboard would stop working for about 5 seconds. Then the problem would go away for a while.

It came back this morning with a vengeance. If I reloaded a browser tab I was guaranteed to freeze my PC.

I had gone searching for solutions before. I’m not the only one with this problem but forum threads were usually:

  • Filled up with replies from people saying, “me too”.
  • A few brave souls asking for log files
  • Suggestions to update firmware and BIOS
  • Solitary pleas for help.

I made sure my SSD firmware was updated (it was) and updated the BIOS of my ASUS P8Z77-M motherboard for the first time to no avail. No change. I was getting ready to put Windows back on the original disk.

Finally, one last desperate search later, I came across this thread and in the same search this page suggesting two methods I hadn’t tried. I did not try disabling LPM (some sort of power saving mod) but I did change the SATA mode from AHCI to IDE. Supposedly the SSD won’t work as well, but it fixed the stuttering and freezes, probably because it apparently disables power saving mode too, or so I’ve read.

Phew. No more stutters! If I hit any performance problems I’ll try the LPM trick with the registry.