Categories
WordPress

WPMU: Please add commentmeta first

I was going to announce WordPress MU 2.9.1 today but I knew that people would run into trouble with the missing commentmeta table if they didn’t upgrade their blogs immediately.

So, download add-commentmeta.txt, rename it to add-commentmeta.php and copy it into your mu-plugins folder. Login to your site as a Site Admin, visit Site Admin->Upgrade and upgrade all the blogs on your site. Make sure you’re using WordPress MU 2.8.6 as the upgrade script in older versions may not execute the plugin.

The script above will add the commentmeta table to each blog. Give it time because it will take quite a while on large sites. WordPress MU 2.9.1 tomorrow.

Comments

comments

By Donncha

Donncha Ó Caoimh is a software developer at Automattic and WordPress plugin developer. He posts photos at In Photos and can also be found on Google+ and Twitter.

28 replies on “WPMU: Please add commentmeta first”

So if I upgrade my site immediately after plopping down the 2.9.1 files, i don’t have to run the add-commentmeta script before hand?

Hi Donncha,

If we only have small WPMU installs (less than 100 blogs), is this step of using the mu-plugin necessary?

ie. will WPMU 2.9.1 try to add this new table as part of its standard upgrade procedure (if I update the core files then run Site Admin -> Upgrade).

For previous versions of WPMU that involve db changes, a separate mu-plugin wasn’t required.

Thanks.

It’s up to you, but I’d create the tables before hand. There’s nothing quite like the stress of upgrading and finding that something has broken. This is one less thing you have to worry about.

I don’t think the missing commentmeta table will crash your blogs or anything but there’s no harm in being prepared and having it done already.

We had some issues upgrading from to WPMU 2.8.6, so we’re still stuck at WPMU 2.7 (auto-upgrade isn’t working yet, so we have to do it manually). I was hoping to upgrade directly to WPMU 2.9.1… Will that be possible?

[…] Men for deg med WordPress MU, oppfordrer Donncha O Caoimh Ã¥ oppgrader installasjonen din før du oppgraderer til versjon 2.9.1. I 2.9.1 kommer det et nytt database felt commentmeta i databasen din – en gang for hver blogg du har. Siden dette kan føre til ekstra “stress” for serveren din, oppfordrer Donncha deg til Ã¥ kjøre et lite script før du gjør selve oppgraderingen. FremgangsmÃ¥te og selve scriptet kan du finne pÃ¥ Donnchas blogg – http://ocaoimh.ie/wpmu-add-commentmeta/. […]

I tried to locate the 2.8.6 download first, but could not find a link to it anywhere on the mu site. I am running 2.8.5.2. Do you think it is safe to upgrade to 2.9.1 directly? Or should I keep hunting down 2.8.6 first?

[…] ויש לכם יותר מעשרות בלוגים במערכת, מומלץ להריץ את תוסף יצירת הטבלאות החדשות לפני השדרוג […]

I went ahead and did the upgrade before seeing your message. I can report that at least for me I had no problem going from 2.8.5.2 to 2.9.1

Great job on this, I am loving the new features already, and I’m sure my users will really love them.

…nothing quite like the stress of upgrading and finding that something has broken.

That’s for sure! I’m sorry I found this post, after upgrading, but very glad to see that commentmeta tables were successfully created on all our 200+ member blogs. I’ll assume that means running Upgrade again with the script installed is not necessary.

Thanks for everything!

[…] 各位在从老版本进行升级的时候,需要注意一点。新版程序为每个子博客都增加了一个名为“commentmeta”的数据库表。请在升级到 2.9.1 之前,先将您的站点升级为 WordPress 2.8.6,然后下载 MU 开发人员在其博客中提到的文本文件。重命名该文本文件为“add-commentmeta.php”并复制到“mu-plugins”目录中。最后,进入“站点管理 -> 升级”对全站的子博客进行升级。这样,该插件会自动为所有的子博客增加所需的数据库表。升级 2.9.1 的方式和之前就没什么区别了,直接覆盖,然后按照提示就可以了。(注意:该插件只能在 2.8.6 下运行,所以务必先升级到 2.8.6 再运行该插件。) […]

Leave a Reply to » WordPress development Things to do before upgrading to WordPress Mu 2.9.1 « Fairweb Cancel reply