[…] Yes, it’s a good idea to upgrade as soon as WordPress 2.6 is officially released. Don’t let hackers enough time to find vulnerabilities in your WordPress 2.5.1 blog. With the new version your blog will be more safe. And if you are still using more old versions, you definitely should upgrade. […]